Power Supply Unit

Discuss all kind of nice gadgets and two way radios here.
Post Reply
User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Tue Jan 12, 2016 8:35 am

Good day,

Hope anyone can help me.

Does anyone know what this brown round thing is? after some googling I think it is a fuse.

It is from a 12VDC 3,2A UPS Power Supply Unit.

Thank you
Regards
Attachments
2016-01-11 18.03.49.jpg
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
ChrisF
Top Web Wheeler
Top Web Wheeler
Posts: 8280
Joined: Thu Sep 17, 2009 2:56 pm
Town: Bellville
Vehicle: Langpad (RAV4)
Real Name: Chris

Tue Jan 12, 2016 8:48 am

do you have a photo from a different angle ?

typically capacitors that release smoke .....

but I dont see any "farad" value .... but then again very often components on commercial pc-boards dont display all info ...

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Tue Jan 12, 2016 8:51 am

I will upload another photo tonight.
But from what I can gather it might be this, http://za.rs-online.com/web/p/products/2260967/" onclick="window.open(this.href);return false;
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
Family_Dog
Moderator
Moderator
Posts: 12727
Joined: Tue May 22, 2007 10:09 am
Town: Klerksdorp
Vehicle: Hilux DC SFA, Hilux 2.7 DC, Hilux 2.7 SC, Prado 95 VX
Real Name: Eric
Club VHF Licence: HC101
Location: Klerksdorp, NW
Contact:

Tue Jan 12, 2016 8:56 am

How many wires from it? You'll have to look at the other side of the PCB for that. It looks more like a full-wave bridge rectifier to me, so will probably have four equidistant leads.

Whatever, it certainly looks like it is now "fused".

Edit: Aah, might be a Wickmann fuse!


-F_D
Image

White Fang: 1999 2.7i DC Raider 4x4
Bull Dog: 1987 4Y-EFI 2.2 DC 4x4
Pra Dog: 1998 Prado VX 3.4
Hound Dog: 2000 2.7i SC 4x4


One Staffie, One Jack Russell, One Ring Neck Screecher, 17 Fish of questionable heritage


Image

User avatar
Stef
Monster Truck
Monster Truck
Posts: 3108
Joined: Mon Jan 25, 2010 12:54 pm
Town: Pretoria
Vehicle: '98 LTD
Real Name: Stefan
Club VHF Licence: X107

Tue Jan 12, 2016 9:01 am

Looks like a fuse yes. Cylindrical (electrolytic) caps are normally used in power supplies are usually marked clearly ito Polarity as well and bulges at the top when blown.

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Tue Jan 12, 2016 9:03 am

Family_Dog wrote:How many wires from it? You'll have to look at the other side of the PCB for that. It looks more like a full-wave bridge rectifier to me, so will probably have four equidistant leads.

Whatever, it certainly looks like it is now "fused".

Edit: Aah, might be a Wickmann fuse!


-F_D
There is 2 wires from it going into the PCB
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
Jaws
LR 4WD Full Lockers
LR 4WD Full Lockers
Posts: 506
Joined: Fri Dec 14, 2007 11:41 am
Town: Sharonlea
Vehicle: 2009 D4D 4x4
Real Name: Herman

Tue Jan 12, 2016 9:40 am

You are correct it's a
Bussmann fuse




Sent from my iPhone using Tapatalk
:thumbup:

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Tue Jan 12, 2016 12:11 pm

So can I buy a new one and just replace it?

Sent from my GT-I9500 using Tapatalk
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
ChrisF
Top Web Wheeler
Top Web Wheeler
Posts: 8280
Joined: Thu Sep 17, 2009 2:56 pm
Town: Bellville
Vehicle: Langpad (RAV4)
Real Name: Chris

Tue Jan 12, 2016 12:51 pm

buy a couple ..... the fuse is not the problem - just an indicator of the actual over current .....

User avatar
Stef
Monster Truck
Monster Truck
Posts: 3108
Joined: Mon Jan 25, 2010 12:54 pm
Town: Pretoria
Vehicle: '98 LTD
Real Name: Stefan
Club VHF Licence: X107

Tue Jan 12, 2016 2:36 pm

+1 Replace and switch on without load, if it blows again there is a short/faulty component on the board.

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Tue Jan 12, 2016 3:14 pm

Stef wrote:+1 Replace and switch on without load, if it blows again there is a short/faulty component on the board.
Thank you, will give it a try :thumbup:
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Wed Jan 20, 2016 7:49 pm

Got the replacement fuses. But as soon as I plug in the unit it blows again. So I guess there is something else wrong.

Sent from my GT-I9500 using Tapatalk
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
Stef
Monster Truck
Monster Truck
Posts: 3108
Joined: Mon Jan 25, 2010 12:54 pm
Town: Pretoria
Vehicle: '98 LTD
Real Name: Stefan
Club VHF Licence: X107

Thu Jan 21, 2016 2:30 pm

Sounds like you have a dead short somewhere between L -N.

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Thu Jan 21, 2016 2:34 pm

Anyway to determine where that would be?

Sent from my GT-I9500 using Tapatalk
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
Stef
Monster Truck
Monster Truck
Posts: 3108
Joined: Mon Jan 25, 2010 12:54 pm
Town: Pretoria
Vehicle: '98 LTD
Real Name: Stefan
Club VHF Licence: X107

Thu Jan 21, 2016 4:01 pm

Easiest is to measure with a multi-meter to see if that is the case...then follow the actual tracks on the back to see if there is any obvious shorts like a piece of wire/solder or maybe against the enclosure when assembled etc.

With that eliminated, check the major components one by one

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Thu Jan 21, 2016 4:10 pm

Will give it a go when I get a chance. Thanks

Sent from my GT-I9500 using Tapatalk
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

User avatar
etiennel22
High Range 4WD
High Range 4WD
Posts: 43
Joined: Mon Oct 12, 2015 3:23 pm
Town: Kempton Park
Vehicle: 2003 Hilux 3.0 KZ-TE D/C Raider 4x4
Real Name: Etienne

Mon Feb 22, 2016 11:59 am

Finally got time to test the unit. So it seems the yellow Polypropylene Film Capacitor next to the Fuse is also dead.
Found a place that sell those capacitors hopefully I can get the unit working tonight. Holding Thumbs
:thumbup: :yahoo: :celebrate: :dance1: :cooldude:

Post Reply

Return to “Electronic Gadgets and Radios”

  • Information
  • Who is online

    Users browsing this forum: No registered users