1kd engine losing power

Having problems with your vehicle? Or need advice on repairing or servicing your Hilux? This is the place to ask for help
Post Reply
sbuyoungbaby
Newbie
Posts: 4
Joined: Mon Dec 04, 2017 6:26 pm
Town: Johannesburg
Vehicle: 3.0l d4d 1kd quantum
Real Name: sibusiso
Location: Johannesburg south Africa
Contact:

Fri Dec 29, 2017 8:56 pm

Hello good people I need help/pointers,well I changed my 2.5l on a quantum n put the 3.0l the 1st fire up was glorious and power was amazing I had full power nothing was wrong at all,now I'm losing power I don't reach 120km easily,well there is this sensor on the inlet manifold I think its called the turbo boost or whatever,this sensor has 3 wires from it,the wires were broke at 1st and it ran well but now some people say that may be the cause to my power loss but guys plz note,this car was performing very well without those wires connected and still they are not connected what might be the problem though,any other sensors or wires or hardware I should look at?
Attachments
IMG-20171215-WA0001.jpg
This is my quantum

User avatar
pietpetoors
Moderator
Moderator
Posts: 10188
Joined: Thu May 17, 2007 9:12 pm
Town: Langebaan
Vehicle: 2.7 Hilux 4x4 DC
Real Name: Pieter
ORRA Call Sign: X27
Contact:

Fri Dec 29, 2017 10:26 pm

Check at the Turbo if ALL the pipes are properly connected. Sometimes a pipe at the turbo gets loose which can cause loss of power.
Only Dead Fish Go With The Flow!
Image
1999 Hilux 2.7i 4x4 Raider DC. Rear diff-lock, Red Peppor Bull Bar and rock sliders, 31" Cooper ST, Snorkel, Alu-Canopy, VHF Kirisun radio, West Coast Rust, Mikem Rear Suspension, Ball Joint Spacers in front, 25watt LED Spots

Post Reply

Return to “The Workshop”

  • Information
  • Who is online

    Users browsing this forum: Mud Dog