Prado 3.0 Kzte Diesel issues

Here we discuss Hiluxes in general. Your view of the Hilux. For other general discussions please see "open Discussions" under the "Around the Campfire" heading.
Post Reply
Franki12
Newbie
Posts: 9
Joined: Mon Jun 19, 2017 2:50 pm
Town: Rustenburg
Vehicle: Prado 3.0 KZTE 120
Real Name: Craig

Mon Jun 19, 2017 5:30 pm

Hi guys, I am hoping someone can assist me here with sound advice.

I have a Prado 120 with 3.0 KZTE motor with auto transmission.
Stunning vehicle, really love it.

We had entire motor redone in December 2016.

In March this year we went on Holiday and were towing a venter trailer, after about 300km it started developing a miss when the revs were under 2000rpm, above 2000rpm it ran perfect. It also started bulging white smoke out the exhaust.

We finished our holiday and returned back to North west, fuel consumption was still fine.
I then sent it back to the guys who done my motor.
After lots of fighting and arguing I received my vehicle back last week after 7 weeks.
They have removed the electric injector pump and installed a manual pump with cable etc, much to my disgust.
The rev counter does not work now, the vehicle has be revved through the roof before it changes gears in the auto box, it is very heavy on fuel as well.
It sounds good and the miss and smoke have gone but that's it.
I don't want to damage my engine again.
A few people have said this conversion cannot be done successfully on a prado with auto box.

What do I do now? I want my car right?
What could the original problem have been because these guys cant give me a straight answer.
The vehicle is so hard to drive now.

Many thanks
Post Reply

Return to “General Hilux Discussions”