91 hilux speedometer not working

Here we discuss Hiluxes in general. Your view of the Hilux. For other general discussions please see "open Discussions" under the "Around the Campfire" heading.
Post Reply
zukin
Newbie
Posts: 3
Joined: Sun Oct 18, 2009 1:47 pm
Town: Abbotsford_Canada
Vehicle: 91 hilux double cab
Real Name: Ray

Fri Aug 10, 2018 8:33 pm

have a 91 hilux double cab 2.8l with manual transmission.
speedometer & odometer stopped working, it has a electronic speedometer no cable.
I have replaced the vehicle speed sensor with no luck.
anyone else had this issue? any ideas or suggestions?

thanks in advance

User avatar
niclemaitre
LR 4WD Full Lockers
LR 4WD Full Lockers
Posts: 696
Joined: Mon Jun 13, 2011 2:44 pm
Town: Stellenbosch
Vehicle: 87 DC 2.8D
Real Name: Nic
Location: Stellenbosch

Mon Aug 13, 2018 9:37 am

I'm speaking under correction but the 91 definitely had a cable speedometer.
Happy trails
Nic

SFA '97 DC affirmatively shopped
SFA '87 DC "Rooies"

User avatar
Mud Dog
Moderator
Moderator
Posts: 28629
Joined: Tue Apr 29, 2008 2:18 am
Town: East London
Vehicle: '90 SFA Hilux DC 4X4, Full OME, 110mm lift. Brospeed branch, 50mm ss freeflow exhaust. 30 x 9.5 Discoverer S/T's on Viper mags. L/R tank. (AWOL) '98 LTD 2.4 SFA, dual battery system. Dobinson suspension, LR tanks, 31" BF mud's.
Real Name: Andy
Club VHF Licence: HC103

Mon Aug 13, 2018 8:52 pm

That would be 100% correct for a '91 model here in RSA, Nic. Ray is however from Canada ... just edited his profile to show that so that it's more obvious in future. :winkx:
When your road comes to an end ...... you need a HILUX!.

Image
Image

Life is like a jar of Jalapeño peppers ... what you do today, might burn your ass tomorrow.
Don't take life too seriously ..... no-one gets out alive.
It's not about waiting for storms to pass. It's about learning to dance in the rain.
And be yourself ..... everyone else is taken!

User avatar
niclemaitre
LR 4WD Full Lockers
LR 4WD Full Lockers
Posts: 696
Joined: Mon Jun 13, 2011 2:44 pm
Town: Stellenbosch
Vehicle: 87 DC 2.8D
Real Name: Nic
Location: Stellenbosch

Tue Aug 14, 2018 12:14 pm

Ah ok, but still, the next generation of Hilux, the IFS, also has a cable. I don't think it was until the Vigo model that there were fully electronic ones
Happy trails
Nic

SFA '97 DC affirmatively shopped
SFA '87 DC "Rooies"

User avatar
Mud Dog
Moderator
Moderator
Posts: 28629
Joined: Tue Apr 29, 2008 2:18 am
Town: East London
Vehicle: '90 SFA Hilux DC 4X4, Full OME, 110mm lift. Brospeed branch, 50mm ss freeflow exhaust. 30 x 9.5 Discoverer S/T's on Viper mags. L/R tank. (AWOL) '98 LTD 2.4 SFA, dual battery system. Dobinson suspension, LR tanks, 31" BF mud's.
Real Name: Andy
Club VHF Licence: HC103

Tue Aug 14, 2018 3:13 pm

I think they used all their old tech stuff in the African market while Europe and the US / Canada got the latest tech at the time. So quite conceivable that they already had the electronic ones by that time. :think:
When your road comes to an end ...... you need a HILUX!.

Image
Image

Life is like a jar of Jalapeño peppers ... what you do today, might burn your ass tomorrow.
Don't take life too seriously ..... no-one gets out alive.
It's not about waiting for storms to pass. It's about learning to dance in the rain.
And be yourself ..... everyone else is taken!

Mars
LR4WD, Lockers, Crawler Gears
LR4WD, Lockers, Crawler Gears
Posts: 1287
Joined: Mon May 07, 2012 12:33 pm
Town: Pretoria
Vehicle: Toyota Hilux Dakar 2.8 GD-6 DC 4X4
Real Name: Marnus
Location: Pretoria Oos
Contact:

Wed Aug 15, 2018 6:42 am

I suspect that you may have an issue in the instrument cluster itself. I would start troubleshooting there.

Post Reply

Return to “General Hilux Discussions”

  • Information
  • Who is online

    Users browsing this forum: No registered users