KZTE electrical gremlin

Having problems with your vehicle? Or need advice on repairing or servicing your Hilux? This is the place to ask for help
Post Reply
jakkie
Newbie
Posts: 5
Joined: Mon Jul 09, 2012 1:37 pm
Town: Port Elizabeth
Vehicle: Toyota KZTE
Real Name: Yacov

Wed Jul 03, 2019 7:55 pm

Hi
My trusted bakkie developed a strange electrical problem.
I started when I removed my radio to replace it. the 12v only measured between 7 and 9 volts, what I can see is the roof light is affected.
When a door is open the roof light and clock light does not work, when I close the door, they come back on, the volts will also drop when I open a door.

Under steering at the fuse box, there is a plug with 3 wires, it is a longish connector when I remove this, the problem sort of goes away and the interior light works with the doors open?!

I measured the power tot remote receiver and this also runs at lower power. My gut feel is an earth wire or something in the integration relay, or power tot he cab.
The lighter is running at full 12v, but that is on the ACC circuit and gets power from the ignition

Not sure if there is anyone with some sort of suggestion.
User avatar
pietpetoors
Moderator
Moderator
Posts: 10496
Joined: Thu May 17, 2007 9:12 pm
Town: Langebaan
Vehicle: 2.7 Hilux 4x4 DC
Real Name: Pieter
Club VHF Licence: X27
Contact:

Wed Jul 03, 2019 9:41 pm

Tumelo on the forum's KZ almost caught fire due to the roof light. I am not sure what the cause was of his problem but it did start at the roof light. Wort stripping out the roof light and start looking there.
Only Dead Fish Go With The Flow!
Image
1999 Hilux 2.7i 4x4 Raider DC with 3.4 Prado V6. Rear diff-lock, Red Peppor Bull Bar and rock sliders, 31" Cooper ST, Snorkel, Alu-Canopy, VHF Motorolla radio, West Coast Rust, Mikem Rear Suspension, Ball Joint Spacers in front, 25watt LED Spots
Mars
LR4WD, Lockers, Crawler Gears
LR4WD, Lockers, Crawler Gears
Posts: 1433
Joined: Mon May 07, 2012 12:33 pm
Town: Pretoria
Vehicle: Toyota Hilux Dakar 2.8 GD-6 DC 4X4
Real Name: Marnus
Location: Pretoria Oos
Contact:

Thu Jul 04, 2019 7:12 am

I agree with you. It sounds like an earth issue. Did it start immediately after replacing the radio? The best bet is to start looking in the vicinity of where you were working when the problem started. You may have disturbed or damaged an earth wire close to the radio.
jakkie
Newbie
Posts: 5
Joined: Mon Jul 09, 2012 1:37 pm
Town: Port Elizabeth
Vehicle: Toyota KZTE
Real Name: Yacov

Thu Jul 04, 2019 7:21 am

yes. started around the same time.
I will strip out the left side of the dash this weekend, which can only be because of the wire movement.
Post Reply

Return to “The Workshop”